// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\x{0600}-\x{06FF}A-z-\d\/_.]+)?").unwrap();
let string = "English_Text/متن-فارسی/Numbers-0123456789/dot-./chars-_.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}