#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Certified by\n?|APPROVED:\n?|approved by:\n?)(\w[^,?].+)"
Local $sString = "SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER" & @CRLF & _
"by" & @CRLF & _
"Chih-Ping Tso" & @CRLF & _
"B.Tech., Loughborough University of Technology, United Kingdom" & @CRLF & _
"(1968)" & @CRLF & _
"Submitted in Partial Fulfillment of" & @CRLF & _
"the Requirements for the Degree of" & @CRLF & _
"Master of Science" & @CRLF & _
"at the" & @CRLF & _
"Massachusetts Institute of Technology" & @CRLF & _
"August 1970" & @CRLF & _
"Signature of Author" & @CRLF & _
"Department of Nuclear Engineering" & @CRLF & _
"Certified by" & @CRLF & _
"Thesis Supervisor" & @CRLF & _
"Accepted by" & @CRLF & _
"Chairman, Departmental Committee" & @CRLF & _
"Archives on Graduate Students" & @CRLF & _
"MASS. INST. TECH." & @CRLF & _
"SEP 21 1970" & @CRLF & _
"LIBRARIES" & @CRLF & _
"" & @CRLF & _
"--------------------------------------" & @CRLF & _
"ASSESSMENT OF A MENTOR PROGRAM" & @CRLF & _
"ON SELF-CONCEPT AND ACHIEVEMENT VARIABLES" & @CRLF & _
"OF MIDDLE SCHOOL UNDERACHIEVERS" & @CRLF & _
"by" & @CRLF & _
"Helene Aiello" & @CRLF & _
"Dissertation submitted to the faculty of the Virginia" & @CRLF & _
"Polytechnic Institute and State University in partial" & @CRLF & _
"fulfillment of the requirements for the degree of" & @CRLF & _
"Doctor of Education" & @CRLF & _
"in" & @CRLF & _
"Administration and Supervision" & @CRLF & _
"Of" & @CRLF & _
"Special Education" & @CRLF & _
"APPROVED:" & @CRLF & _
"Philip R. Jones, Chairman Kenneth Underwood" & @CRLF & _
"Sylvia Auton" & @CRLF & _
"Shirley Jones Ronald McKeen" & @CRLF & _
"February 22, 1988" & @CRLF & _
"Blacksburg, Virginia"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")