import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Certified by\\n?|APPROVED:\\n?|approved by:\\n?)(\\w[^,?].+)";
final String string = "SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER\n"
+ "by\n"
+ "Chih-Ping Tso\n"
+ "B.Tech., Loughborough University of Technology, United Kingdom\n"
+ "(1968)\n"
+ "Submitted in Partial Fulfillment of\n"
+ "the Requirements for the Degree of\n"
+ "Master of Science\n"
+ "at the\n"
+ "Massachusetts Institute of Technology\n"
+ "August 1970\n"
+ "Signature of Author\n"
+ "Department of Nuclear Engineering\n"
+ "Certified by\n"
+ "Thesis Supervisor\n"
+ "Accepted by\n"
+ "Chairman, Departmental Committee\n"
+ "Archives on Graduate Students\n"
+ "MASS. INST. TECH.\n"
+ "SEP 21 1970\n"
+ "LIBRARIES\n\n"
+ "--------------------------------------\n"
+ "ASSESSMENT OF A MENTOR PROGRAM\n"
+ "ON SELF-CONCEPT AND ACHIEVEMENT VARIABLES\n"
+ "OF MIDDLE SCHOOL UNDERACHIEVERS\n"
+ "by\n"
+ "Helene Aiello\n"
+ "Dissertation submitted to the faculty of the Virginia\n"
+ "Polytechnic Institute and State University in partial\n"
+ "fulfillment of the requirements for the degree of\n"
+ "Doctor of Education\n"
+ "in\n"
+ "Administration and Supervision\n"
+ "Of\n"
+ "Special Education\n"
+ "APPROVED:\n"
+ "Philip R. Jones, Chairman Kenneth Underwood\n"
+ "Sylvia Auton\n"
+ "Shirley Jones Ronald McKeen\n"
+ "February 22, 1988\n"
+ "Blacksburg, Virginia";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}