# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Certified by\n?|APPROVED:\n?|approved by:\n?)(\w[^,?].+)"
test_str = ("SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER\n"
"by\n"
"Chih-Ping Tso\n"
"B.Tech., Loughborough University of Technology, United Kingdom\n"
"(1968)\n"
"Submitted in Partial Fulfillment of\n"
"the Requirements for the Degree of\n"
"Master of Science\n"
"at the\n"
"Massachusetts Institute of Technology\n"
"August 1970\n"
"Signature of Author\n"
"Department of Nuclear Engineering\n"
"Certified by\n"
"Thesis Supervisor\n"
"Accepted by\n"
"Chairman, Departmental Committee\n"
"Archives on Graduate Students\n"
"MASS. INST. TECH.\n"
"SEP 21 1970\n"
"LIBRARIES\n\n"
"--------------------------------------\n"
"ASSESSMENT OF A MENTOR PROGRAM\n"
"ON SELF-CONCEPT AND ACHIEVEMENT VARIABLES\n"
"OF MIDDLE SCHOOL UNDERACHIEVERS\n"
"by\n"
"Helene Aiello\n"
"Dissertation submitted to the faculty of the Virginia\n"
"Polytechnic Institute and State University in partial\n"
"fulfillment of the requirements for the degree of\n"
"Doctor of Education\n"
"in\n"
"Administration and Supervision\n"
"Of\n"
"Special Education\n"
"APPROVED:\n"
"Philip R. Jones, Chairman Kenneth Underwood\n"
"Sylvia Auton\n"
"Shirley Jones Ronald McKeen\n"
"February 22, 1988\n"
"Blacksburg, Virginia")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.