// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Certified by\n?|APPROVED:\n?|approved by:\n?)(\w[^,?].+)").unwrap();
let string = "SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER
by
Chih-Ping Tso
B.Tech., Loughborough University of Technology, United Kingdom
(1968)
Submitted in Partial Fulfillment of
the Requirements for the Degree of
Master of Science
at the
Massachusetts Institute of Technology
August 1970
Signature of Author
Department of Nuclear Engineering
Certified by
Thesis Supervisor
Accepted by
Chairman, Departmental Committee
Archives on Graduate Students
MASS. INST. TECH.
SEP 21 1970
LIBRARIES
--------------------------------------
ASSESSMENT OF A MENTOR PROGRAM
ON SELF-CONCEPT AND ACHIEVEMENT VARIABLES
OF MIDDLE SCHOOL UNDERACHIEVERS
by
Helene Aiello
Dissertation submitted to the faculty of the Virginia
Polytechnic Institute and State University in partial
fulfillment of the requirements for the degree of
Doctor of Education
in
Administration and Supervision
Of
Special Education
APPROVED:
Philip R. Jones, Chairman Kenneth Underwood
Sylvia Auton
Shirley Jones Ronald McKeen
February 22, 1988
Blacksburg, Virginia";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}