#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(http|https):\/\/www.biologiatotal.com.br\/areas-da-biologia\/[^\/]+\/?([?r=]+[0-9]+)?$"
Local $sString = "https://www.biologiatotal.com.br/areas-da-biologia/zoologia/?r=4955"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")