$re = '/^(http|https):\/\/www.biologiatotal.com.br\/areas-da-biologia\/[^\/]+\/?([?r=]+[0-9]+)?$/';
$str = 'https://www.biologiatotal.com.br/areas-da-biologia/zoologia/?r=4955';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);