re = /^(http|https):\/\/www.biologiatotal.com.br\/areas-da-biologia\/[^\/]+\/?([?r=]+[0-9]+)?$/
str = 'https://www.biologiatotal.com.br/areas-da-biologia/zoologia/?r=4955'
# Print the match result
str.match(re) do |match|
puts match.to_s
end