package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http|https):\/\/www.biologiatotal.com.br\/areas-da-biologia\/[^\/]+\/?([?r=]+[0-9]+)?$`)
var str = `https://www.biologiatotal.com.br/areas-da-biologia/zoologia/?r=4955`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}