import re
regex = re.compile(r"SushiRoles.*:.*\"MMa\"")
test_str = "<AuthZ><PersonaId:\"1090553942\"></PersonaId><SushiRoles 123:abc \"MMa\"></SushiRoles><R:\"1090553939\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")