// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"SushiRoles.*:.*\"MMa\""#).unwrap();
let string = "<AuthZ><PersonaId:\"1090553942\"></PersonaId><SushiRoles 123:abc \"MMa\"></SushiRoles><R:\"1090553939\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}