using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+\.)+([^\s]*)(?:\.\d+)+";
string input = @"09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}