package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d+\.)+([^\s]*)(?:\.\d+)+`)
var str = `09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}