$re = '/(?:\d+\.)+([^\s]*)(?:\.\d+)+/';
$str = '09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 test 09.04.EXAMPLETEXT.14 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);