using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"content\/(\w+)\/(\w+)\/(\d+)\/([^\/]+[\w]+)\/?(\w*)$";
string input = @"content/foo/B6128/8918/foo+bar+foo/7867786
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}