package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)content\/(\w+)\/(\w+)\/(\d+)\/([^\/]+[\w]+)\/?(\w*)$`)
var str = `content/foo/B6128/8918/foo+bar+foo/7867786
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}