re = /content\/(\w+)\/(\w+)\/(\d+)\/([^\/]+[\w]+)\/?(\w*)$/i
str = 'content/foo/B6128/8918/foo+bar+foo/7867786
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end