const regex = /content\/(\w+)\/(\w+)\/(\d+)\/([^\/]+[\w]+)\/?(\w*)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('content\\\/(\\w+)\\\/(\\w+)\\\/(\\d+)\\\/([^\\\/]+[\\w]+)\\\/?(\\w*)$', 'i')
const str = `content/foo/B6128/8918/foo+bar+foo/7867786
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}