#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([Gg]0?[01]) *(([XxYyZz]) *(-?\d+.?\d*)) *(([XxYyZz]) *(-?\d+.?\d*))? *(([XxYyZz]) *(-?\d+.?\d*))?"
Local $sString = "G1 X110.406 Y109.680 E6.01498" & @CRLF & _
"G1 X110.768 Y109.508 E6.02854" & @CRLF & _
"G1 X111.167 Y109.404 E6.04252" & @CRLF & _
"G1 X111.596 Y109.379 E6.05707" & @CRLF & _
"G1 X112.009 Y109.439 E6.07118" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")