package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([Gg]0?[01]) *(([XxYyZz]) *(-?\d+.?\d*)) *(([XxYyZz]) *(-?\d+.?\d*))? *(([XxYyZz]) *(-?\d+.?\d*))?`)
var str = `G1 X110.406 Y109.680 E6.01498
G1 X110.768 Y109.508 E6.02854
G1 X111.167 Y109.404 E6.04252
G1 X111.596 Y109.379 E6.05707
G1 X112.009 Y109.439 E6.07118
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}