using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Sorry,[^<>]*\(([0-9]+)\)";
string input = @"Sorry, this is temporarily unavailable. (103)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}