$re = '/Sorry,[^<>]*\(([0-9]+)\)/m';
$str = 'Sorry, this is temporarily unavailable. (103)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);