package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Sorry,[^<>]*\(([0-9]+)\)`)
var str = `Sorry, this is temporarily unavailable. (103)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}