re = /Sorry,[^<>]*\(([0-9]+)\)/m
str = 'Sorry, this is temporarily unavailable. (103)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end