using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\w+)[^=;]+)=?\s*([^;]+)";
string input = @"int i;
String s;
public int go = 23; sdfsdfsdfsdf
public static final int value,valu2;
public static final String t,t1,t2 = 23;
String myString=""25"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}