import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\w+)[^=;]+)=?\\s*([^;]+)";
final String string = "int i;\n"
+ "String s;\n"
+ "public int go = 23; sdfsdfsdfsdf\n"
+ "public static final int value,valu2;\n"
+ "public static final String t,t1,t2 = 23;\n"
+ "String myString=\"25\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}