re = /^((?:\w+)[^=;]+)=?\s*([^;]+)/m
str = 'int i;
String s;
public int go = 23; sdfsdfsdfsdf
public static final int value,valu2;
public static final String t,t1,t2 = 23;
String myString="25";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end