// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:\w+)[^=;]+)=?\s*([^;]+)").unwrap();
let string = "int i;
String s;
public int go = 23; sdfsdfsdfsdf
public static final int value,valu2;
public static final String t,t1,t2 = 23;
String myString=\"25\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}