const regex = /[\s\w]+?-\s*[A-Z]{2}(?=<\/div>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\w]+?-\\s*[A-Z]{2}(?=<\\\/div>)', 'g')
const str = `<div class="endereco-item">
<h2 class="azulclaro identify">Casa</h2>
<div class="entrelinha_0"></div>
<div class="font_15"></div>
<div class="font_15"></div>
<div class="font_15">R: Antonio Pires dos Santos, 647 praça central</div>
<div class="font_15">Parque santo antonio - Sao Paulo - SP</div>
<div class="font_15">CEP: 55555-555</div>
<div class="font_15">Fone: (11)943-056-295 (55)555-555-555</div>
<div id="ctl00_Body_rptEnderecos_ctl00_dvRadio" class="font_15 custom-checkbox">
<input type="radio" id="radio0" name="radioSelect" checked onclick="setPrincipal(0)" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}