package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d.+]|(.)\++`)
var str = `+345+5453+54`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}