const regex = /[^\d.+]|(.)\++/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d.+]|(.)\\++', 'g')
const str = `+345+5453+54`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);