$re = '/[^\d.+]|(.)\++/';
$str = '+345+5453+54';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;