use strict;
my $str = '+345+5453+54';
my $regex = qr/[^\d.+]|(.)\++/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";