const regex = /(?<={"Reception#"}).{{36}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<={"Reception#"}).{{36}}', 'gm')
const str = `ReceptionService#1caf6329-d175-4ca8-b0b1-a79139477b7aService#add0c0fb-a91b-42f6-ac0f-e1f0b8c98343Reception#809faced-4549-40b5-b711-3cae0ed19de5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}