import Foundation
let pattern = ##"(?<={"Reception#"}).{{36}}"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"ReceptionService#1caf6329-d175-4ca8-b0b1-a79139477b7aService#add0c0fb-a91b-42f6-ac0f-e1f0b8c98343Reception#809faced-4549-40b5-b711-3cae0ed19de5"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)