$re = '/(?<={"Reception#"}).{{36}}/m';
$str = 'ReceptionService#1caf6329-d175-4ca8-b0b1-a79139477b7aService#add0c0fb-a91b-42f6-ac0f-e1f0b8c98343Reception#809faced-4549-40b5-b711-3cae0ed19de5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);