use strict;
my $str = 'ReceptionService#1caf6329-d175-4ca8-b0b1-a79139477b7aService#add0c0fb-a91b-42f6-ac0f-e1f0b8c98343Reception#809faced-4549-40b5-b711-3cae0ed19de5';
my $regex = qr/(?<={"Reception#"}).{{36}}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}