package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*?(\d+)\s+(\d+)(?:\s+(\d+))?\s*(?:!.*)?$`)
var str = ` 12 3
1 2
12 3 !comment
1 2 !comment
1 1
1 1 !comment
16653 2 1
16654 2 1
16654 2 1 ! comment
16654 2 1 ! comment
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}