import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*?(\\d+)\\s+(\\d+)(?:\\s+(\\d+))?\\s*(?:!.*)?$";
final String string = " 12 3\n"
+ " 1 2 \n"
+ " 12 3 !comment\n"
+ " 1 2 !comment \n"
+ " 1 1\n"
+ " 1 1 !comment \n"
+ " 16653 2 1\n"
+ " 16654 2 1 \n"
+ " 16654 2 1 ! comment\n"
+ " 16654 2 1 ! comment \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}