import Foundation
let pattern = #"^\s*?(\d+)\s+(\d+)(?:\s+(\d+))?\s*(?:!.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
12 3
1 2
12 3 !comment
1 2 !comment
1 1
1 1 !comment
16653 2 1
16654 2 1
16654 2 1 ! comment
16654 2 1 ! comment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)