$re = '/^\s*?(\d+)\s+(\d+)(?:\s+(\d+))?\s*(?:!.*)?$/mx';
$str = ' 12 3
1 2
12 3 !comment
1 2 !comment
1 1
1 1 !comment
16653 2 1
16654 2 1
16654 2 1 ! comment
16654 2 1 ! comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);