# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!^)<[^>]*>(?!$)//gm;t' <<< "<color=yellow>Hello <color=cyan>World!</color></color>
<color=yellow>Hello my <color=cyan>name</color> is <color=gray>Kite <color=white>Watson!</color></color></color>"