use strict;
my $str = '<color=yellow>Hello <color=cyan>World!</color></color>
<color=yellow>Hello my <color=cyan>name</color> is <color=gray>Kite <color=white>Watson!</color></color></color>';
my $regex = qr/(?<!^)<[^>]*>(?!$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";