re = /(?<!^)<[^>]*>(?!$)/m
str = '<color=yellow>Hello <color=cyan>World!</color></color>
<color=yellow>Hello my <color=cyan>name</color> is <color=gray>Kite <color=white>Watson!</color></color></color>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result