$re = '/(?<!^)<[^>]*>(?!$)/m';
$str = '<color=yellow>Hello <color=cyan>World!</color></color>
<color=yellow>Hello my <color=cyan>name</color> is <color=gray>Kite <color=white>Watson!</color></color></color>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;