package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<string>id<\/string>|<string>\d+<\/string>|<string>label<\/string>|<string>(.*?)<\/string>`)
var str = `<map>
<entry>
<string>id</string>
<string>555</string>
</entry>
<entry>
<string>label</string>
<string>Need This Value</string>
</entry>
<entry>
<string>key</string>
<string>748</string>
</entry>
</map>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}