$re = '/<string>id<\/string>|<string>\d+<\/string>|<string>label<\/string>|<string>(.*?)<\/string>/';
$str = '<map>
<entry>
<string>id</string>
<string>555</string>
</entry>
<entry>
<string>label</string>
<string>Need This Value</string>
</entry>
<entry>
<string>key</string>
<string>748</string>
</entry>
</map>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);