import re
regex = re.compile(r"<string>id<\/string>|<string>\d+<\/string>|<string>label<\/string>|<string>(.*?)<\/string>")
test_str = ("<map>\n"
" <entry>\n"
" <string>id</string>\n"
" <string>555</string>\n"
" </entry>\n"
" <entry>\n"
" <string>label</string>\n"
" <string>Need This Value</string>\n"
" </entry>\n"
" <entry>\n"
" <string>key</string>\n"
" <string>748</string>\n"
" </entry>\n"
"</map>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")