using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:youtube(?:-nocookie)?\.com\/(?:[^\/]+\/.+\/|(?:v|e(?:mbed)?)\/|.*[?&]v=)|youtu\.be\/)([^""&?\/ ]{11})";
string input = @"http://youtu.be/dQw4w9WgXcQ ...
http://www.youtube.com/embed/dQw4w9WgXcQ ...
http://www.youtube.com/watch?v=dQw4w9WgXcQ ...
http://www.youtube.com/?v=dQw4w9WgXcQ ...
http://www.youtube.com/v/dQw4w9WgXcQ ...
http://www.youtube.com/e/dQw4w9WgXcQ ...
http://www.youtube.com/user/username#p/u/11/dQw4w9WgXcQ ...
http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/dQw4w9WgXcQ ...
http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ ...
http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ ...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}