# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:youtube(?:-nocookie)?\.com\/(?:[^\/]+\/.+\/|(?:v|e(?:mbed)?)\/|.*[?&]v=)|youtu\.be\/)([^\"&?\/ ]{11})"
test_str = ("http://youtu.be/dQw4w9WgXcQ ...\n"
"http://www.youtube.com/embed/dQw4w9WgXcQ ...\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ ...\n"
"http://www.youtube.com/?v=dQw4w9WgXcQ ...\n"
"http://www.youtube.com/v/dQw4w9WgXcQ ...\n"
"http://www.youtube.com/e/dQw4w9WgXcQ ...\n"
"http://www.youtube.com/user/username#p/u/11/dQw4w9WgXcQ ...\n"
"http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/dQw4w9WgXcQ ...\n"
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ ...\n"
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ ...")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.